Fedora11のyum update で依存エラー2009年11月12日 10時58分

先日、Fedora11にアップグレードしたサーバーで、「yum update」をしてみた。すると「libnetfilter_conntrack.so.1 is needed by package iptstate-2.2.1-5.fc11.i586(installed)」というエラーが出て、アップデートできない。なんとなく「libnetfilter」というものが依存の関係上必要であると言われているのは分かるのだが。

解決策をネットで探すと、海外サイトで発見。噛み砕いて言うと、どうやらFedora11には「libnetfilter_conntrack.so.3」というのが入っているらしいが、iptsate-2.2.1-5という奴が「libnetfilter_conntrack.so.1がまだ必要だよぅ」といってゴネているらしい。

解決策:

yum --sikip-broken update

で依存関係の不具合を無視してアップデートする。今度は無事に成功。しかし、このまま依存関係問題を放置でいいのかは不明。